Anonymous
10 Jul, 2018

How to fix phpmyadmin error, incorrect format parameter that appeared while importing a database?

1 Answer         94527 Views

Webtrickshome
10 Jul, 2018

phpMyAdmin Error - incorrect format parameter might appear due to multiple reasons such as:

  • Execution of a script exceeding the defined maximum execution time.
  • Parsing of requested input data exceeds the defined maximum input parsing time.
  • Script needing operating memory higher than the one defined in memory limit.
  • Size of post data higher than the defined maximum post data size.
  • Size of the file being uploaded higher than the defined maximum file size.

All of the above stated settings are defined in php.ini file whose path is xampp/php/php.ini. You can open the xampp application and click on the config option beside the apache controls and click on the php.ini from the dropdown list that appears.

Search for the above stated settings with the help of the phrases stated below and set their values higher as needed. Here's my personal settings.

max_execution_time = 3000
max_input_time = 60
memory_limit = 128M
post_max_size = 200M
upload_max_filesize = 200M	

Apart from those changes, it's better to ensure the collation of the newly created database is exactly the same as the one which is being imported to avoid further issues within the application because of the characters.

Restart your apache server and check if it works for you. In most of the cases, this problem occurs because of the size of the database file being imported and the time it takes to get executed. You can compress the database file to a .zip file and try to import it.

If the error still exists, open the xampp/phpmyadmin/libraries/config.default.php and disable the script execution time limit. Search for the phrase ExecTimeLimit as show below.

$cfg['ExecTimeLimit'] = 300;

All you have to do is change the ExecTimeLimit value to 0 to get it disabled.

$cfg['ExecTimeLimit'] = 0;

Add a comment if your problem still persists and we'll try to explore it and get solutions.


218 Likes         0 Dislike         2 Comments        


Eve

11 Aug, 2021

My problem persists

Jiwan Thapa

21 Aug, 2021

Hi Eve, will you be more specific about the error?

Reply


Alonso

03 Sep, 2021

I still keep getting the error "phpMyAdmin - Error Incorrect format parameter" Centos 7 / WHM after setting up a php.ini file as you have above. Editing the $cfg['ExecTimeLimit'] = 300; set to 0 from a command line. Restarting Apache - I get the same error after importing the SQL file. Any other thoughts? I also tried this and still no fix. https://bobcares.com/blog/phpmyadmin-error-incorrect-format-parameter/

Jiwan Thapa

05 Sep, 2021

Generally, we get this error on localhost not in WHM. Still, try compressing your sql file to zip and then try uploading it to phpmyadmin. If the issue still exists, you can open your sql file in text editor and then copy sql command for each table and upload it one by one. If your sql file is corrupted, you'll get the error. Else, your database table will be uploaded.

Reply



Leave a comment